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About the Tutonial

SAP Crystal Reports is a business intelligence tool helps in generating reports from SAP as
well as non-SAP data sources. Knowledge of this tool is a plus for managers and business
leaders who can generate quality advanced level reports which will help them in making
better strategic decisions.

This tutorial covers the key concepts of SAP Crystal Reports and how you can use it to
generate professional reports.

Audience

This tutorial is designed for those who want to learn how to generate simple as well as
advanced reports for end-users using the specialized tool of Crystal Reports.

Prerequisites

Crystal Reports is quite a user-friendly tool. It can be easily learnt. All that you need is a
basic knowledge of how to connect with the database from where the data is to be drawn
to generate the reports.

Disclaimer & Copyright

© Copyright 2020 by Tutorials Point (I) Pvt. Ltd.

All the content and graphics published in this e-book are the property of Tutorials Point (I)
Pvt. Ltd. The user of this e-book is prohibited to reuse, retain, copy, distribute or republish
any contents or a part of contents of this e-book in any manner without written consent
of the publisher.

We strive to update the contents of our website and tutorials as timely and as precisely as
possible, however, the contents may contain inaccuracies or errors. Tutorials Point (I) Pvt.
Ltd. provides no guarantee regarding the accuracy, timeliness or completeness of our
website or its contents including this tutorial. If you discover any errors on our website or
in this tutorial, please notify us at contact@tutorialspoint.com.
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1. Overview

SAP Crystal Reports is a Business Intelligence tool which is used to generate reports from both
SAP and non-SAP data sources. It enables end users to generate reports that includes exceptional
visualizations and implement new business requirements into reports to reduce dependency on IT
and Report developers.

SAP Crystal Reports can connect to any data source that include Relational databases like
Oracle, OLAP data source systems like BW, or also with XML data. You can create a simple report
or you can also use complex or specialized tool of Crystal Reports to create advance level reports
for end users. It is mostly used for pixel perfect reporting for CEO’s and Managers.

Benefits of Using Crystal Reports

Flexible and customized report: You can quickly create highly formatted, pixel-perfect reports
using SAP Crystal Reports with high level design interface and efficient workflows.

Powerful report delivery options: You can deliver personalized reports to your business end-
users in their preferred language and format.

Data source connectivity: You can connect to information sources directly. Data sources
include: Native, ODBC, OLE DB, and JDBC connectivity to relational, OLAP, web services, XML,
enterprise data sources, and salesforce.com.

Expanded support for Excel: You can take full advantage of the Excel file format by allowing
more data to be exported to a single worksheet, without spanning multiple worksheets.

Windows operating system compatibility: SAP Crystal Reports software 2013 is certified
compatible with Microsoft Windows 7.

Mobile compatibility: You can also open interactive reports through your mobile devices.

SAP Crystal Reports, Adobe Flash and HTML 5 integration: It enables SAP Crystal Reports
developers to produce powerful "mash-ups" pulling data from various sources.

Competitors: SAP Crystal Reports competes with several products in Microsoft market like SQL
Server Reporting Services SSRS, XtraReports, ActiveReports, and List & Label.

Installation Requirements for Crystal Reports

Following are the basic requirements to install Crystal Reports:

e PC with AMD or Intel based processors, Dual Core CPU, 2 GB RAM
e Approximately 4GB available hard drive space (for English only, 8 GB for all languages)

e Microsoft Windows 7 SP1, Windows 8, Windows Server 2008 SP2, Windows Server 2008
R2 SP1, Windows Server 2012
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Languages available: English, Finnish, French, German, Hungarian, Italian, Japanese, Korean,
Norwegian, Polish, Portuguese, Chinese simplified, Chinese traditional, Czech, Danish, Dutch,
Slovakian, Slovenian, Spanish, Swedish, Thai, Turkish, Romanian, Russian

Technical Specifications

¢ Hardware Requirements: Intel Pentium III or equivalent processor, minimum 512 MB
RAM recommended

e Disk Space: 2 GB for default installation with English language, 4 GB for default installation
with all languages installed

Versions and Features Comparison

Let us take an example to decode the SAP Crystal Reports version format. Assume 12.1.2.957.12
is the version of CR 2008. Here 1 signifies that it is Service Pack 1, .2 signifies that Fix Pack 1.2
has been applied on top of Service Pack 1. The last three of four digits are not important. Another
example, if you have version 12.3.1.684, I know I am using CR 2008, Service Pack 3, Fix Pack
3.1.

Editions — Developer (D), Professional (P), Standard (S)

SAP Crystal Version
Reportsfor  for version
Enter- Visual for

High-Productivity Report Creation Features 2016 2013 2011 2008 prise* Studio  Eclipse XI
Wizards and experts for report creation x x x x X x X DPS
Database expert for graphical table linking X X x X X x X DP,S
Field explorer to manage report fields x X X x X x x DpP,S
Drill down in runtime b X X X X x % DPS
Autosave X X X X X DP,S
Editable preview window X b X X X X DP,S
Browse field data X % x X X X X DPS
Move, resize, and multiselect objects X X X X X X X DP,S
Custom templates X X X X X DPS
Repository for component reuse b3 X X x X DpP
workbench tool for managing projects X X X b3 x DS
Automatic patch notification and installation X X x X x x DPS
Start page to stay connected with latest information x X X x x X DPS
HTML preview X X X X x X X DpP
Extension points for custom wizards, toolbar, buttons, and designer %
events
Extension points for toolbar buttons x X X x X
Multilingual report design and view x X X b3 x
Dual monitor support X X x x X X x
Freehand SQL command object to optimize relational queries x X x x X
verify database options X X x x X
New range based functions X
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Editions — Developer (D), Professional (P), Standard (S)

SAP Crystal version
Reports for  for Version
Enter- Visual for

Comprehensive Formatting and Design Control Features 2016 2013 2011 2008 prise* Studio _ Eclipse x
Cross-tab objects X x X X x x X DPS
Subreport objects X X X x x X x DPS
Save subreport as stand-alone report X X X X X X DPS
Text objects ©s X x x X x x DPS
Line and box objects X X x X X X x DPS
Multipass reporting with powerful grouping and sorting x % x x x X x DP,S
Top-n and bottom-n sorting X X x X X X X DPS
Sorting on groups and detail records X x x x x x x DPS
Hierarchical grouping X X x X X X X DPS
Custom (named) grouping X X x X X x x DpP,S
Conditional font and text formatting X x X X X % x DPS
Formula control of formatting X X X x X x x DPS
Text rotation X x X X X x x DPS
Integrated charting X X X X X % x DPS
Chart on subtotals, group details, and formulas X X X X X X x b,P,S
BLOB bitmap support X % x X X X x DPS
Graphic image support for BMP, TIFF, JPEG, PNG, PCX, TGA, and PICT 3 = ? % = 3 ¥ 0ps
formats
BasiC-like syntax in formula language x X X X X % DPS
Hierarchical group summary X X X X X X DPS
Support for Unicode data and text X X x X X X x DS
Display string formatting X X X X X X X DPS
Support for vector-based images x x x X x X x DPS
Formula workshop for building formulas x x X x x x X DPS
Custom functions to reuss logic X x x X x X X DPS
Define report parts for portal integration X X x X X DPS
Format painter to reuse formatting X X x X X X X DPS
Horizontal page numbers X % x X X X x DPS
Parameterized n value for top-n style reports X X x X X X DPS
Drag-and-drop charting and cross-tabs X X X X X X DPS
Dynamic image location x X X X X X % DPS
Save export options within the report X X x X X DPS
Add XSLT transform to XML export X x x X x
Flash objects x X x X x Runtme  Runtime
Cross-tab calculated members for custom rows and columns X X x X X
Insert blank lines in cross-tabs X x X X X
Change parameters without refreshing data X X X X X X x
Page break after n-detail records X X x X X X Runtime
Page size measured in pixels X X x x x X Runtime
Formula-driven page margins X x x X X X Runtime
Portrait or landscape orientation by section X X X X X X Runtime
Optional parameters X X X X X X Runtme
Built-in bar-code support X x x X X Runtime  Runtime
vertical alig of text within cell X
Editions — Developer (D), Professional (P), Standard (S)

SAP Crystal Version

Reportsfor  for version

Enter- Visual for

Interactive Analysis Tools 2016 2013 2011 2008 prise* Studio  Eclipse X1
Smart navigation: group tree, drill down, and search X x x X X X x DpPS
Geographic maps X X X x X DpPS
Customizable cross-tabs X x X X X x x DPS
Report alerts X X X X X DPS
Integrated analyzer for charts X X X X X DpP,S
Conditional formatting on charts X x X X X DPS
Drill-down-level functionality X x X x X x x DPS
On-report sort controls for interactive sorting X X X x X X Runtime
Parameter panel for interactive filtering and formatting X x X X X Runtime  Runtime
Adobe Flash integration (embed SWF objects) X X X X X Runtime  Runtime
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Editions — Developer (D), Professional (P), Standard (S)

SAP Crystal version

Reports for  for version
Enter- Visual for
Report Types 2016 2013 2011 2008 prise* Studio  Eclipse Xi
Mailing labels X X X x % DP,S
Cross-tab reports X X X X % x X DPS
Form-style reports x X X X X X x DP,S
Subreports X X X X x X x DPS
Conditional reports X X x X X x X DP,S
Top-n and bottom-n reports x X X x X X x DPS
Drill-down and summary reports X x X X x X X DPS
OLAP reports X X X X x° D.pP
SAP Crystal version
Reports for  for version
Enter- visual for
Chart Types 2016 2013 2011 2008 prise® Studio _ Eclipse Xi
Bar, stacked bar, column, stacked column x X X X x X X DPS
Line, area, pie scatter, bubble X X X X X X X DPS
Gantt, gauge X X X X x X X DPS
Numeric or date-time x-axis X X X x x x X DPS
Funnel X X x X x X X DpP,S
Stock, 3D Surface, 3D Rise, Radar, Histogram, Donut, XY Scatter X X X x X X X DPS
Box plot, Tag Cloud, Tree Map, Waterfall X X
SAP Crystal Version
Reportsfor  for version
Enter- Visual for
SAP HANA® platform support 2016 2013 2011 2008 prise* Studio _ Eclipse X1
Relational data access [JDBC and ODBC) X x x X

Relational semantic layer support (UNX)
Multidimensional access to SAP HANA analytical and calculation views

x
xs
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2. GUI Navigation

Crystal Reports for enterprise provides an interface that enables you to quickly and easily create,
format, and publish effective reports.

The menu bar provides full range of features available in Crystal Reports for Enterprise as shown
in the following image.

{ SAP Crystal Reports for Enterprise
File Edit Yiew Insert Format Data Help

B~ - | - | | T2 - ~ Insert |/F|:|rmat |~ Data |

|

| | | Text ™, Line Box | {5 Group » ==]Section | £ Total = < Sort Contral = |

SAP CRYSTAL REPORTS FOR ENTERPRISE

MEYY RECEMT DOCUMENTS

[ From Data Source
B Frorm Web Template. ..

The standard toolbar as shown in the following image allows you to access common Report
functions such as: Open an existing report, create a new report, save a report, print a report, cut,
paste, export and undo.

File Edit “iew Insert Format Data Help
i iy

O - & - | - | ar - < Insert | Format J Data

| | | y, 88 Groups Sork | Record Filker Interactive Filker | Formmul

SAP CRYSTAL REPORTS FOR ENTERPRISE

MNEWY RECENT

[ From Data Source
B From Web Template...

The Insert tab allows you to insert objects into you report, such as inserting a text, line, box,
groups, sections, pictures, calculations and/or charts, as shown in the following image.
5

@ tutorialspoint

EIMPLYEAEYLEARMNINEG



Crystal Reports

Data Help

- Insert! | Format | Data |

( Text ™ Line B Group - section | X Total - aort Contral - Chart = Cross-tah -+ Picture Flash 5] subreport %] Page Mumber )

SAP CRYSTAL REPORTS FOR ENTERPRISE m

The Format tab as shown in the following image, allows you to use functions for formatting the
selected field such as: changing the font size or font color, background color, alignment of text to
center, left, right, etc.

It also allows you to apply conditional formatting, such as highlighting values above or below a
specific threshold value in the report.

aka Help

- “Insert J Format! |~ Data |

™
( o B/ U|ES R R e

SAP CRYSTAL REPORTS FOR ENTERPRISE

When you click on conditional formatting option at top right corner, the formatting box open. In
this box, you define the condition under which you want conditional formatting to appear. In
setting area, specify the formatting to appear when condition is met, like changing font style or
color of text.

The Data tab as shown in the following figure, enables you to work with data-editing queries,
creating groups and sorts, applying filters to limit data in the report and creating formulas to add
custom calculations to reports.

- “Insert | Farmat J Data:

@E Groups Sark Record Filker Inkeractive Filker Formulas | <. Subreport :)

SAP CRYSTAL REPORTS FOR ENTERPRISE

When you click on Query filter option or on Edit data sources, as shown in the following image, a
query panel opens. In the Query panel, you can select objects that you want to see in the report.
In the filter option, you can apply filters to restrict the data returned by the report.
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Uintitled - SAP Crystal Reports Ffor Enterprise

File Edit “Wiews Insert Formak Daka Help

™ - - - | & - Insert | Formak J Data |
585 Groups ‘%J, Sork  CQuery Filcer 7 Interactive Filter 5 Formulas
- Mew - Options - Edit Query

B - Result Objecks

Edit Diata Sources. .. *

= Uél___f:-.?LI;Sn'I:JEnSx I—IE 19 | W2 | [ Wiew scripk | [ [ |

EI_ _:I Cusktomer

Edit the query used ko retriewe wour daka.

4= Universe : SALES DJ Result Objecks Fq
Foeees w —usktomer Mame — — :‘ﬁ "
=1-{_1 Fack Sales g = 2% 24
e W Juantity Sold Fegion 0
0 Rogion Currency Quankity Sald |
s W Region Mame Customer
= | o) FProduct
ormulas H
Fack Sales Query Filters For
FParamekters (00 Tirmne

rera
Running Tokals {00 & < lﬁ
Predefined Objeck=s

| ¥\ v\ r

When you click on Formula button, as shown in the following image, the Formula workshop opens.
This allow you to use custom calculations in the report. You can apply formulas by typing or by
clicking on objects, functions and operators in the data explorer.

- Insert | " Format J Data |
25 Groups ‘E‘l Sork 7 Cwery Filker  “/ Interactive Fiker | 5 Formulas . Subreport
‘ | Skruckure Page

- Formula Workshop

= Simple o Show All - ‘%‘.I, Sark By Type - Celete Formula | Ei New - | A 4 (7 IExcf

Eg Mavigation |:1§| Ohjects

=l S_ele::tin:ln Formulas Record Filter

N =cord Filker
-y @roup Filker
ey Saved Data Filker Group Filter
----- Formulas
I= Formatting Formulas
[+ Lintitled Saved Data Filter
----- Functions

The main working area in Crystal Reports is known as Report Design Canvas and is divided into
structure tab and page tab. Crystal Report is divided into five different parts by default and
additional sections are added if you apply grouping to the report.
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Struckure

Report Header

Page Header

.ReportTitle

woditicationDate

Quantity Sold .

Customer Hame

Region

M ame

Body

Guantity Sold. Customer Name

Region Marne

REeport Footer

Page Footer

b

Using the Structure tab, as shown in the above image, you can create the overall structure by
placing items in various sections of the report. You can also apply any required sorting, grouping,
etc. Here, you work with placeholders for data and not data itself.

The Page tab, as shown in the following image, displays the report data on the basis of the
structure you created in the structure tab. Here, you can evaluate formatting and layout of the
report design for distribution.

Data Explorer

New = Options -

» Result Gbjects

Edit Data Sources...

-0 PROJECT.nx
=7k PROJECT

EI E] Customer

1 Custarner Addr

o fy Customer Name

EID Fack Proj

Repott Header

f Page Header

945

Customer Name
3400 Anand
2300 Jack
3300 Ana

Customer Addr
BOSTOM, MA

SAN JOSE, CA
HOUSTON, TX

Region Name
WASHINGTON
MUMBAI
NEWDELH

Country
USA

[NDIA
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3. Report Options

Report Options is one of the most commonly used feature in Crystal Report Designer, when you
need to access/modify the values of Report Options of a Crystal report at runtime in a Crystal
Reports .NET application.

Go to Edit -> Report Options
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Report Options feature is used to set various fields in a Crystal Reports such as, smart guidelines
feature that lets you select, move, and resize entire columns of report elements without needing
to manually select each element. When you select a report element, the smart guidelines appear
and automatically select related elements in the column.
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4. Page Layout

SAP Crystal Report gives two options of page layout - landscape and portrait. Landscape means
the page is oriented horizontally, while portrait means the page is oriented vertically.

To open Page Layout option in Crystal Report, go to File-> Page Setup.
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This option allows you to choose page options like: Paper size, paper width, paper height, and
margins (left, right, top and bottom).

To change the page layout:
Select the Page Setup tab in File Menu. Click the Orientation option in the Page Setup group.
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Crystal Reports

—Page Opkions
Paper Size I-m |
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Paper Width | 5.5 in _
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End of ebook preview
If you liked what you saw...

Buy it from our store @ https://store.tutorialspoint.com
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