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About the Tutorial 

Microsoft Expression Web is a full-featured professional tool for designing, developing, and 

publishing feature-rich websites that conform to web standards. Expression Web uses its 

own standard rendering engine, which is different from Internet Explorer's Trident engine.  

In the following chapters of this tutorial, we will look closely at Microsoft Expression Web 

and learn how it works.  

Audience 

This tutorial has been prepared for aspiring web designers to familiarize them with the 

interface and features of Microsoft Expression Web.  

After completing this tutorial, you will gain sufficient knowledge on Microsoft Expression 

Web from where you can take yourself to the next level. 

Prerequisites 

It is quite a simple tutorial written in a very user-friendly manner. You can make the most 

of it with a very basic knowledge of web designing and web development.  

Disclaimer & Copyright 

 Copyright 2018 by Tutorials Point (I) Pvt. Ltd.  

All the content and graphics published in this e-book are the property of Tutorials Point (I) 

Pvt. Ltd. The user of this e-book is prohibited to reuse, retain, copy, distribute or republish 

any contents or a part of contents of this e-book in any manner without written consent 

of the publisher.   

We strive to update the contents of our website and tutorials as timely and as precisely as 

possible, however, the contents may contain inaccuracies or errors. Tutorials Point (I) Pvt. 

Ltd. provides no guarantee regarding the accuracy, timeliness or completeness of our 

website or its contents including this tutorial. If you discover any errors on our website or 

in this tutorial, please notify us at contact@tutorialspoint.com. 
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Microsoft Expression Web is a full-featured professional tool for designing, developing, and 

publishing feature-rich websites that conform to web standards. You can use Expression 

Web to create web pages and sites that let you transfer files between your computer and 

your hosting account.  

Expression Web can design and develop web pages using HTML5, CSS 3, ASP.NET, PHP, 

JavaScript, XML+XSLT and XHTML.  

Expression Web 4 requires .NET Framework 4.0 and Silverlight 4.0 to install and run. 

Microsoft Expression Web − History 

Microsoft released the first Community Technology Preview (CTP) version of Expression 

Web on May 14, 2006.  

Microsoft Expression Web 4 was released on June 7, 2010.   

 It added the option of HTML add-ins and access to a web-based functionality for 

testing pages on browsers that cannot be installed on the user's system, such as 

Mac OS X or Linux browsers.  

 

 It also provides an SEO Checker using which you can analyze already created 

websites against the best practices for getting the highest possible search engine 

rankings. 

Expression Web Service Packs 

Expression Web 4 Service Pack 1 was released in March 2011 and added support for 

IntelliSense for HTML5 and CSS.  

Expression Web 4 Service Pack 2 was released in July 2011. It fixed a number of issues 

and introduced new features such as  

 jQuery IntelliSense support  

 a panel for managing snippets  

 Interactive Snapshot Panel 

 comment/uncomment functionality in Code View, and  

 workspace and toolbar customization. 

In December 2012, Microsoft announced that Expression Studio will no longer be a stand-

alone product. Expression Blend is being integrated into Visual Studio, while Expression 

Web and Expression Design will now be free products. 

 

1.   Expression Web − Overview 
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System Requirements 

To create a website using Microsoft Expression Web, your computer should meet the 

following requirements: 

 You should have at least Windows XP with Service Pack 3 or the latest operating 

systems. 

 

 You should have a PC with 1 GHz or faster processor. 

 

 Your PC should have 1 GB of RAM or more. 

 

 Your PC should have 2 GB or more of available hard disk space. 

 

 You should have .NET Framework 4.0 and Silverlight 4.0. 

 

 Your PC should support Microsoft DirectX® 9.0 graphics.  

 You should have DVD compatible drive. 

 

 You should have 1024 x 768 or higher resolution monitor with 24-bit color. 

 

 Some product features require Firefox 3.0 or later, Internet Explorer 8. So you 

should have the same version. 

Actual requirements and product functionality may vary based on your system 

configuration and operating system. 
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Microsoft provides a free version of Microsoft Expression Web which can be downloaded 

from https://www.microsoft.com/en-pk/download/details.aspx?id=36179. 

Installation  

Step 1: Before you can install Expression Web, you will need to have .NET Framework 4.0 

installed.  

Step 2: Once downloading is complete, run the installer. The following dialog will be 

displayed. 

 

Step 3: Click the Accept button. 

Step 4: Select the Yes radio button and then click Next. 

2.   Expression Web − Environment Setup 

https://www.microsoft.com/en-pk/download/details.aspx?id=36179
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Step 5: You can choose other location as well for installation. Select the location and click 

the Install button. 
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The installation process starts. 

 

Once the installation is complete, you will see the following dialog. 

 

Step 6: Click Finish to continue. 
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In the previous chapter, we have installed Microsoft Expression Web and now we are ready 

to start working on it. In this chapter, we will learn how to create a new website from 

scratch.  

Create a Website 

To create a new website, let’s open Microsoft Expression Web. 

 

Next, you need to follow the steps given below. 

 

 

 

 

 

 

 

 

3.   Expression Web − New Website 
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Step 1: Select Site -> New Site… menu option.  

 

Step 2: It will open the following dialog from which you can create or import different 

types of website. 
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Step 3: For simplicity let’s select General -> One Page Site.   

 Specify the location or you can browse to the location where you want the new 

website to be created. 

 

 Type in the name of your web in the name field and click OK. 
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Step 4: The new web will be created with one page named default.htm. Let’s rename it 

to index.html with a right-click on the file and clicking on the Rename option. 
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Step 5: The default doctype used in Expression Web is: 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 

"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 

<html xmlns="http://www.w3.org/1999/xhtml"> 

You can see it by just switching to the code view. 
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You can change the doctype from Tools -> Page Editor Options -> Authoring. 
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Step 6: Now, let’s add <h1> tag inside the body tag and some text as shown in the 

following code. 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 

"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 

<html xmlns="http://www.w3.org/1999/xhtml"> 

<head> 

    <meta content="text/html; charset=utf-8" http-equiv="Content-Type" /> 

</head> 

<body> 

    <h1> 

        This my first Web page 

    </h1> 

</body> 

</html> 

Step 7: To see our web in a browser, let’s go to the File menu and select the Preview in 

Browser -> Any browser, let’s say, Internet Explorer. 
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It will open our web in Internet Explorer.  

 

 



Microsoft Expression Web 

 

14 

 

As we have already created our website, now we will need to create our Home Page. In 

the previous chapter, we have created a one-page website, and our Home Page was 

created at that time automatically by Expression Web. So, if you have created a blank 

website, then you will need to create a Home Page for your site. 

Microsoft Expression Web can create the following types of pages: 

 HTML 

 ASPX 

 ASP 

 PHP 

 CSS 

 Master Page 

 Dynamic Web Template 

 JavaScript 

 XML 

 Text File 

In this chapter, we will create an HTML page and its corresponding style sheet.  

Create a Blank Page 

To create a blank page, you can simply go to File menu and select New -> Page… menu 

option. 

 

4.   Expression Web − Blank Web Page 
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From the new dialog, you can create different types of blank pages such as HTML page, 

ASPX page, CSS page, etc. and click OK. 

 

As you can see here, the default code is already added by Microsoft Expression Web. 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 

"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 

<html xmlns="http://www.w3.org/1999/xhtml"> 

 

<head> 

<meta content="text/html; charset=utf-8" http-equiv="Content-Type" /> 

<title>Untitled 1</title> 

</head> 

 

<body> 

    <h1> 

        This is a blank web page 

    </h1> 

</body> 

</html> 
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As you can see, your newly created page has the file name Untitled_1.html or 

Untitled_1.htm.  You will need to save the page by pressing Ctrl + S and specify the 

name.  

As our website already contains an index.html page, we don’t need another one. 

However, if you have created an Empty website, then name this page index.html.  

To see your web in a browser, let’s go to the File menu and select the Preview in Browser 

-> Any browser, let’s say Internet Explorer. 
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Create a CSS Page 

Let’s take you through the step-by-step process of creating a CSS page. 

Step 1: To create a CSS page, go to the File menu and select New -> Page… menu 

option. 
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Step 2: Select General -> CSS and click OK. 

 

Step 3: Save the page and type a name for the style-sheet.  
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Step 4: Click the Save button. 

 

Step 5: Now, let’s go to the index.html page. 
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Step 6: In the Manage Styles Panel, click Attach Style Sheet. 

 

Step 7: Browse to your style-sheet and select the Current page from “Attach to” and Link 

from “Attach as” and click OK. 

 

Step 8: Now, you will see that a new line is added automatically in the index.html page. 

<link href="sample.css" rel="stylesheet" type="text/css" /> 
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Step 9: The body element defines the document's body. To style the <body> tag, we 

need to create a new style. First, select the body tag in Design View and then click on the 

New Style… in Apply Styles panel or Manage Styles panel, which will open the New Style 

dialog.  

 

Here, you can define the different options for your style. The first step is to select the body 

from the Selector dropdown list and then select the Existing style sheet from “Define in” 

dropdown list.  
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Step 10: From the URL, select the sample.css file. On the left side, there is a Category 

list like font, background, etc. and currently the Font is highlighted. Set the Font related 

information as per your requirements as shown in the above screenshot and click Ok. 

 

Step 11: Now you can see in the design view that the background color and the font has 

changed to what we have selected. Now, if you open the sample.css file, you will see that 

all the information is automatically stored in the CSS file. 
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Let’s preview our web page in a browser. You will observe that the style is applied from 

the CSS file. 
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End of ebook preview 

If you liked what you saw… 

Buy it from our store @ https://store.tutorialspoint.com 


