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SAP Lumira

About the Tutorial

SAP Lumira is known as a visual intelligence tool that is used to visualize data and create
stories to provide graphical details of the data.

Data is entered in Lumira as dataset and you can apply filters, hierarchies, and columns
to prepare documents. You can choose various charts like Bar charts, Pie charts, etc. to
visualize the data effectively. This basic tutorial explains how to use SAP Lumira.

Audience

SAP Lumira is meant for Business Analysts who can alter data structures and correlations
in whatever way they want. They can create data visualizations and stories from multiple
data sources. SAP Lumira helps to adapt data to organizational needs to create stories
with visualizations.

Prerequisites

Before you start proceeding with this tutorial, we are assuming that you are already aware
of the basics of SAP HANA. If you are not exposed to SAP HANA, then we will suggest you
first to go through our short tutorial on SAP HANA.

Copyright & Disclaimer

© Copyright 2018 by Tutorials Point (I) Pvt. Ltd.

All the content and graphics published in this e-book are the property of Tutorials Point (I)
Pvt. Ltd. The user of this e-book is prohibited to reuse, retain, copy, distribute or republish
any contents or a part of contents of this e-book in any manner without written consent
of the publisher.

We strive to update the contents of our website and tutorials as timely and as precisely as
possible, however, the contents may contain inaccuracies or errors. Tutorials Point (I) Pvt.
Ltd. provides no guarantee regarding the accuracy, timeliness or completeness of our
website or its contents including this tutorial. If you discover any errors on our website or
in this tutorial, please notify us at contact@tutorialspoint.com
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1. Lumira — Overview

SAP Lumira is known as a visual intelligence tool to create and visualize stories on dataset.
It was earlier known as Visual Intelligence tool where you could visualize data and create
stories to provide graphical details of the data.

Data is entered in Lumira as data set and you can apply filters, hierarchies, calculated
columns to build documents on Lumira. You can choose various charts like Bar charts, Pie
charts, etc. to visualize the data effectively.

Example

You can put multiple charts on a story page to create presentation and can add images
and text fields in these pages.

These stories can be published to other platforms using the publish option in the
application:

e SAP Business Object BI Platform
e SAP Business Object Explorer

e SAP Lumira Server

e SAP HANA

e SAP Community Network (SCN)

Features of Lumira

The key features of Lumira are as follows:

e It allows you to predict future outcomes and forecast as per the changing market
situations.

e You can create data visualizations and stories from multiple data sources.

e It helps you to adapt data to organizational needs to create stories with
visualizations.

e You can share the visualizations on different platforms like SAP HANA, BO Explorer,
Business Objects BI Platform, etc.

Key Terms of SAP Lumira Data Set

Data is entered in Lumira as dataset and it contains Attributes/Dimensions and
Measures.

e Measure: Measures are defined as numerical data types. Example: Quantity sold,
Revenue, Unit Price, Average cost, etc.

e Attributes/Dimensions: Data containing details about the measures is called
Attributes or Dimensions in dataset. This represents the object on which analysis
is done. Example: Customer, Product, Order, Time, Region, etc.
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Hierarchies: Hierarchies are used for drilling the data to sub levels and defines a
parent-child relationship. Example: Time Hierarchy, Region hierarchy.

e Custom Calculations: You can create custom calculations in Lumira data
Visualization, which are not available in data set or at database level. Example:
You have a “Salary” column in the data set, you can add a new calculated column
with name “"Bonus” and can apply a calculation on Salary to get the value of this
column.

. SAFP Lumira

File Edit e Data Help Prepare Wi

L] « " SYS_ BIC"."A_SANJUANY SALES" v

Mo filter applied currenthr on the dataset

MEASURES 2 ﬁ
o NETAMT o 4BC  CUSTID 10 4BC CUSTID_1 10
=TT cum C101 C101
C102 c102
DIMENSIONS 24 10s 10s
— 4{1 Gregarian_Hierarchy c104 c104
ABG VEAR c105 c105

SAP Lumira—User Interface

When you login to Lumira Data visualization tool, there are four tabs at the top:

Prepare

Prepare is used to import data set in SAP Lumira. Data is cleansed and converted into
appropriate measures or attributes for the reports. You can add new custom calculations
here.

Visualize

The Visualize tab is used to add graphs and charts on the data that has been imported
and organized in Prepare tab. You can add different attributes and measures to the Label
axis.
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SAP Lumira
R Edt o View  Data  felp JOTICM Visualize  Compose  Share
[ « " SYS BIC""A SANJUIANY SALES' v
h No filter applied currently on the dataset
MEASURES 2
= NETAMT Sum 6C CUSTID 10 #C CUSTID 1 10 BOLANG 1
= TANT Sum C101 0101 EN
Compose

The Compose tab is used to create stories and presentations, including background colors,
titles, pictures, and text.

Share

The Share tab is used to publish your visualizations to different platforms or with different
set of users in the BI Repository.
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2. Lumira — Data Sources

You can use different data sources with SAP Lumira to create a data set. A data source
can be an Excel file, text file, clipboard, HANA Information Models, Universe created in
IDT/UDT, SQL query, connected to a BEx Query or an info provider.

Once you open SAP Lumira, go to File -> New Data set

File Edit wIE Data Help
3
[ ey Cirl+

HAME
[Create a new dataset | ‘
Impart ta folder... CArl+]

You can select from various Data sources to create a new data set.

@ Add new dataset

Select a Eource:ﬁ

Microsoft Excel
Load an Excel Waorksheet as a dataset

Text
Load a text file (*.csw, ™t > l0Q,* prn " 1sv) as a dataset

Copy from Clipboard
Copy from Cliphoard

Connect to SAP HANA
Connect to data in an SAP HARNS, Wiew

Download from SAP HANA
Diownload data from an SAFP HARA view as a dataset

Universe
Connect to & Universe and download & dataset

b X+

Query with SOL
Fun freehand SCIL on a database to download a dataset

Connect to SAP Business Warehouse
Connect to & BEx Cluery or an InfoRProvider

All Recently Useg

&5

Q@ & & @ 0O @

ANY_SALES
hest_SvS_AId)

SALE_WIEW A
hestl 5YS_BIG

SAP HANA daty

TEST_AMNA
hest_SvS_AId)

DEMP_ANA
hestl 5YS_BIG

SHOW_AMA
hest_SvS_AId

TEST_CAL
hestt 55 _BIG

¥
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3. Lumira — Data Acquisition

The key steps in Data acquisition are as follows:

e For data acquisition in SAP Lumira, create a new document that will contain the data
and visualization of acquired data.

e Next is to connect to a data source, which contains data for visualization.
e Acquire the data to create a data set.

e Data acquisition can be done from multiple compatible data sources to use in a single
visualization or data analysis.

¢ Once data is acquired, it comes under the Prepare tab.

File Edit N Data Help

| a
RT3 e+
| [Create a new dataset| ﬁ HAME

e Select a Data Source. Enter the system details from where the data is to be acquired
and click Next.

Select a Source: ﬁ Recently Used: Connect to SAP HANA
Microsoft Excel 55 ANV_SALES
Load an Excel Worksheet as a dataset bhesti_SYS_BICHA_SANIL
Text &) SALE_VIEwW_ANA
Load a text file (*.csv,™ b, log,”.prn,* tsv) as a dataset best_svS_BIC/pras2

X
@
E=
Qs
&

TEST_ANA

Copy from Clipboard
hestl_SY¥S_BlCiprashanthi

Copy from Cliphoard
DEMP_ANA

Connect to SAP HANA _
hestr_S¥5_BlICipras?.sai

Connect to data in an SAP HA

Download from SAP HANA
Download data from an SAP HAMA view as a dataset

hestl_SY¥S_BlCiprashanthi

&5
&5
&5 sHow_ana
&5

TEST_CAL

Universe best_SvS_BICiprashanthi
Connect to a Universe and download a dataset

Query with SOL
Run freehand SGL on a database to download a[Query with SoL |

Connect to SAP Business Warehouse
Connect to a BEx Query or an InfoProvider

@ tutorialspoint

EIMPLYEAEYLEARMING



SAP Lumira

@ Add new dataset

Connect to SAP HANA
Searvar: best

Instance/Paort: o3 i A

™ Authenticate by Operating System (S50)
Lser: HAMALISER

Fassword: ...........|

I Save Password

—

e Select a Data source like SAP HANA View and click Next.

Select a SAP HANA View Dataset Mame:

Q AMA_TESTZ
=1 H3 Available Views (3420 AMA_TESTZ
= E010(2)
# AM_DISC
# AN_TRANS
EE1118AL (3
# ANA_TESTI

# CAL_CE_SALES
= R} as_BGE (1)

¢ CE_PLAMN_ACTUAL_BGE
= ERARILA (20

# SALES

» ZSALES
= R AT_Region (1)

o AW_SALES
= A_SARIU (5

o ANY_DISC

Previous

Next
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e Select Dimensions and Measures and click Create.

SAP Lumira

Previous

Measures (1) Dimensions {3)
Q Q
=2 Measure Name =2 Dimension Name ¥  values Preview
~ == ponus Surrﬁ ¥ AEC DEPTMNAME ‘ Y  cClickhere to 88 sample values
~ ABC EMPID h 4 Click here to see sample values
I ABC EMPRAME h 4 Click here to see sample values

. SAP Lumira

File Edit e Data Help

Prepare Vi

MEASURES 1

= BONUS Sum Ai:  DEPTNAME §
MS2

DIMENSIONS 3 b

462 DEPTMAME APAG

[] i "UEYE_BICT " T TsALANA_TESTZ 'K

Ho filter applied currenthy on the dataset

ABZ  EMPID 3
Al
B1
1
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4. Lumira — Editing Acquired Data

Let us learn how to edit the acquired Data. Follow the steps given below.

1. To edit data in SAP Lumira, go to the Data tab and click Edit Data Source from the
menu.

B3 5AFP Lumira

File Edit i Data Help Prepare Vit

Edit data source Ctrl+Shift+E

O »
\ Edit data source
|:-:| Y+

« " SYS_BI]

MEASURES 1

2. It will take you to Edit Data Source window, where you can again select Measures and
Dimension.

3. You can check or uncheck any of the attributes and measures to add to data set and
click the OK button.

@ Edit data source

Select Measures and Dimensions

[ Show only selected

Measures {1) Dimensions (3)
Q Q

Values Preview

=

I Measure Name § Dimension Name 4

Click here to see sample values

=

3 = ponyus Sum ABC DEPTMNAME

Click here to see sample values

=

ABC EMPID

444~

Click here to see sample values

=

ABC EMPMNAME

N

li Cancel
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5. Lumira —Viewing Connections

In SAP Lumira, you can check all the connections for an existing application and document
associated with each connection and you can change the data source for an existing
connection.

To view existing connections, close all the data set.

1. Click New and close the Add new data set window. In the left pane, it will show you
the Connections option.

File Edit e Data Help
€3 Home =

HAME
E iy ltems
@ sale pro
E Documents
il wisualizations @ sql_lumira
fs} Datasets @ Reportl

D.Elm Stories

SAaPF Lumira Cloud

SAFP Lumira Edge Server
SAP Bl

Connections 6 2

2. A new window will open with a list of all the existing connections and associated
documents. Click a connection and you can change the target data source.

e % & O

CONNECTIONS (2) s DOCUMENT FOR beStﬁ

Q Q
¥  HName Type

B SAP HANA database 1.0 I sale_prolums Document

! ¥  Report!.lums Document

f best

02¢hanauser

SAP HAMNA Server hest
SAFP HAMNA Server Instance | 03

User Mame: HANAUSER
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6. Lumira — Excel File as a Data Source

You can use an Excel file to create data set in SAP Lumira.

Follow the steps given below.

1. Go to File -> New (Create a data set).

File Edit Rl Data Help

| CONNECTIONS (2}
[+ ey Cirl+M
Q,

| Irmportto fold|Create & new dataset |

2. Select a Source: Load an Excel worksheet as a dataset and click the Next icon at the
bottom.

@ Add new dataset

Select a Source:

[‘K Microsoft Excel

Recently Used: I

Load an Excel Worksheet as a dataset

3. Browse the path of .xls file. You have an option to choose the first row as column
names. You can hide a particular column from .xls by selecting the Select All option.

10
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4. You can click the Advance option to select a custom range. You can also include hidden
rows and columns. Once correct options are selected, click the create button at the
bottom.

= o
® Add new dataset
Dataset Mame: Mew Microsoft Office Excel Warksheet.
File(s): Cillsersthanal TiDesktopiMew Microsoft Office Excel Worksheetxlsy; ] Add Files
Sheet Sheetl w [ Append all sheets @ Setfirst row as column names
Table Header Type: Standard Tahle (Mo Transfarmations) -
¥ Select Al i3 columns - 5 rows
¥ Emp ™ ¥ EMP WAME ¥ SALARY
1 John 34564
2 Anma 2500
3 Sally 4500
4 Jazon so0o0

Advanced Options  ~

Range Selection: u ¥ Show hidden columns

Calumn: Row: 1w V' show hidden rows \
I Detect merged cells

Previous Create Cancel

5. All the data with integer values appear under Measures and all the columns appear
under Dimensions. This data will come under the Prepare tab.

. SAP Lumira

File Edit WiEw Data Help Yisualize

L % New Microsoft Office Excel Wurksheet.){lsx...‘
Mo filter applied currently on the dataset
MEASURES 2
Emp ID EMP NAME SALARY
s EmplD [ Sum |
& DALARY Sum 123 ABC 123
4 Jason a000
DIMENSIONS 3
A ‘ 5 Jim 2400
L EmplD
! 3 Sally 4500
EBG EMP MARME
1 Jdahn 3486
123 SALARY
2 Anna 2500
11
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6. Go to the Visualize tab at the top to create the visualization on top of the data set.

ﬁ vl e v[ [l v All Measures
B SALARY
MEASURES
Hdis o
SALARY (+] E
w
w
2
DIMENSIONS )
o
A =
M w
o\
\_e endCoIor I I I I I I I I I I
9 000 &0000 100k A0k 200k 280k 300k 3A0k 400k 4A0k  S00K
0 SALARY
12
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7. Lumira —Working with CSV Files

You can use a Text file as a data set like .csv file, .txt file, .log file, .prn file, .tsv file.

The following steps explain how to use a text file as a data set.

1. Go to File -> New -> Add New Dataset -> Next.

& Add new dataset

Select a Source:

X

Microsoft Excel
Load an Excel Worlisheet as a dataset

Text

[I! Load & text file (*.csw ™ td, 100 " orn,= tsv) as

Recently Used: T

2. Select the path of csv file, for example an Excel file. You can set the first row as column

names. Select the separator as comma, tab, etc.

The Advance option can be used to select the Number and Date format. Click the Create

button to enter the data in the Prepare tab.

> Q
@ Add new dataset
Dataset Mame: Mew Microsoft Office Excel Worksheet
File(s): ClJzersthanal N\DeskiopiMew Microsoft Office Excel Worksheet cay, [ ] Add Files
Separatar: & Delimited By | Comma v ¥ Setfirst row as column names

€ Fived Width ‘

¥ Select Al 313 columns - 5 rows
¥V Em ID V EMP HRME MV  SALARY

1 Tohn 3456

2 Arma 2500

3 Sally 4500

4 JTason s000

5 Tim 2400

Advanced Options w

Murnber format H [ Trim leading spaces

*Trailing spaces are automatically removed
Date format: Widinnny v
Break Column:
Previous Cancel
Lo
tutorialspoint
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SAP Lumira
File Edit WiEw Data Help Prepare Visualize
L] « Mew Microsoft Office Excel Worksheet.osy  w

[
~y,

Mo filter applied currenthy on the dataset

MEASURES 2 '
= Emp ID EMP NAME SALARY
Emp 1D [ Sum |

o= SALARY Surn 123 ABC 123

4 Jason A000
DIMENSIONS 3 = | 2400

im

(2 ErmpID
! 3 Sally 4500
AB: EMP RAME

1 John 1456
123 SALARY

2 | Anna 24500
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End of ebook preview
If you liked what you saw...
Buy it from our store @ https://store.tutorialspoint.com
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